Installation

Install package with pip

To install with pip:

$ pip install scikit-build

Install from source

To install scikit-build from the latest source, first obtain the source code:

$ git clone https://github.com/scikit-build/scikit-build
$ cd scikit-build

then install with:

$ pip install .

or:

$ pip install -e .

for development.

Dependencies

Python Packages

The project has a few common Python package dependencies. The runtime dependencies are:

wheel>=0.29.0
setuptools>=28.0.0

The build time dependencies (also required for development) are:

codecov>=2.0.5
coverage>=4.2
cython>=0.25.1
flake8>=3.0.4
path.py>=8.2.1
pytest>=3.0.3
pytest-cov>=2.4.0
pytest-mock>=1.4.0
pytest-runner>=2.9
pytest-virtualenv>=1.2.5
six>=1.10.0

Compiler Toolchain

The same compiler toolchain used to build the CPython interpreter should also be available. Refer to the CPython Developer’s Guide for details about the compiler toolchain for your operating system.

For example, on Ubuntu Linux, install with:

$ sudo apt-get install build-essential

On Mac OSX, install XCode to build packages for the system Python.

On Windows, install the version of Visual Studio used to create the target version of CPython

CMake

Download standard CMake binaries for your platform. Alternatively, build CMake from source with a C++ compiler if binaries are not available for your operating system.